
WELCOME! 
 

Welcome to the Stripper program.  In not so many words, the Stripper takes the monthly billing 

report from your Centigram, and converts it into an easy to read Excel spreadsheet which may be 

sorted on a number of user defined criteria, and printed in a report format which can also be 

changed by the user.  (Custom Sorting, and Report formatting require working knowledge of 

Microsoft Excel).  This current version of Stripper has been tested on Centigram software 

versions 5.02 and 5.03C. 

 

The only requirements to use Stripper are:  

 

• A PC compatible computer connected to your Centigram via Serial/Null Modem cable or 

modem. 

• VT-100 Terminal emulation software such as Procomm, capable of capturing screen data to a 

file on disk. 

• Sufficient amount of free disk space for work files (10 MB will work) 

• Microsoft Excel version 5.0 or higher (Requires MS-Windows 3.1 or higher) 

• The free time required to download the monthly billing report. 

 

That’s all there is to it!  I hope you will find this program to take the ordinarily mundane and 

resource intensive chore of producing the monthly billing report, and make it a quick and simple 

task. 

 

This documentation is designed to take the smallest amount of computer literacy for granted, 

with the exception of limiting the instructions on terminal program features to that of Procomm, 

if you are using a different terminal program, you will need to check your operations manual for 

specific key operations. 

 

To Install Stripper: 

1. Place the 3.5” Installation diskette in your drive, change to that drive by entering either “A:” 

or “B:” depending on which it is. 

  

2. Enter “INSTALL”.  Stripper will be placed in a directory called “C:\STRIPPER”, and a 

batch file called “STRIPPER” will be placed in your root directory allowing you to call up 

the program from any DOS prompt by entering “STRIPPER”. 
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Step One: Download the billing report 
 

You will need to gain access to your Centigram via your terminal program.  If your system does 

not give you access to it through an automated menu, you will need to load the program from the 

DOS prompt “C:\>“. 

If your terminal program is Procomm, you should be able to load it by entering: 
CD\PROCOMM 

PROCOMM 

 

For Procomm Plus: 
CD\PCPLUS 

PCPLUS 

 

(note each line must be ended by pressing “ENTER”) 

 

You now need to access the Centigram main menu.  Depending on how you are connected to 

your Centigram, you will either first need to press “ENTER” to obtain a “Log in” prompt, or 

simply press <CTRL><Z> to get to the “Enter Passcode:” prompt.  After you have signed 

in you will see the Centigram main menu: 

 

(c) All Software Copyright 1983, 1991 Centigram Corporation 

All Rights Reserved. 

 

         MAIN MENU 

 

(M) Mailbox maintenance 

(R) Report generation 

(S) System maintenance 

(X) Exit 

 

Enter letter in () to execute command. 

When you need help later, type ?. 

 

COMMAND (M/R/S/X): 

 

Select the Report menu by typing “R” at the menu prompt and pressing enter.  You will then be 

presented with the report menu. 



 

Stripper Manual Page      Revised 01/01/18 3 

Report Menu Prompt: 

 
COMMAND (B/C/D/E/F/G/H/I/J/L/M/P/R/S/T/U/V/X): 

 

Select the Billing report sub-menu by entering “B”.  You will then be presented with the billing 

report menu: 

 

BILLING Report Menu: 

 

(A) Adjust rates 

(B) Billing report 

(G) Gather data 

(M) Mailbox Blocked report 

(P) Previous billing report 

(T) Termination report 

(X) Exit 

 

COMMAND (A/B/G/M/P/T/X): 

 

There are three different reports that Stripper can read: 

(B) Billing Report (Which contains current billing information for the previous month) 

(P) Previous billing report (Billing report from the month before last) 

(T) Termination report (Current mailbox statistics) 

 

To Download Billing Reports: 

To download the Current Billing Report, Enter “B”.  For the Previous Month’s report, enter “P”.  

With the exception of one additional prompt both billing report Procedures are identical.  If you 

selected the (P) previous month’s report, you will see the following prompt: 

Where should billing data come from? (F/H/X) 

Enter “H” for Hard Disk.   

In both reports you will be presented with the following series of prompts: 

 

Billing Report Prompts: 

Report destination (c/s1/s2) [c]: 

 range of extensions to bill? (start-end) [hit return for all]  

FCOS service to bill? (1-64) [hit return for all or ? for help] 

LCOS service to bill? (1-64) [hit return for all or ? for help] 

GCOS service to bill? (1-64) [hit return for all 32,000 or ? for help] 

NCOS service to bill? (1-64) [hit return for all or ? for help] 

department code to bill? [hit return for all] 

pager system number to bill? [hit return for all] * Pause Here 

 



 

Stripper Manual Page      Revised 01/01/18 4 

For the total cumulative monthly billing report, you will want to simply press “ENTER” for all of 

these prompts. (Note, for custom reports, you can limit the Billing report to a particular range of 

mailboxes, or a certain ID code for companies, etc.)  

 

At the prompt:  “pager system number to bill? [hit return for all]”, 

pause for a moment.  At this point you will want to tell Procomm that you wish to turn on the 

screen capture (Log File) feature by press <ALT>[F1], a pop-up Window will prompt you for a 

file name.   

 

Chose an 8 letter description for your report, ending it with the extension of  “.RPT” and the 

path “C:\STRIPPER\”.   (Example: “C:\STRIPPER\BILL1294.RPT”). 

 

Press “ENTER” ONCE to  enter the file name and start the Log File (Status Bar Will Display 

“Log OPEN”)  Then press “ENTER” again to start the billing report.   

 

The billing report will dump to your screen, but will also be captured to a text file on disk with a 

name you specify.   

 

Note that running this billing report will in most cases take quite some time (at least an hour), 

and it might want to be something you do over night.  Also, while the report is running, in most 

cases, you won’t be able to access your Centigram for normal use. 

 

To Download a Termination Report: 
COMMAND (A/B/G/M/P/T/X): 

Enter “T” from the Billing Report Menu.  You will see the following prompts: 
 

Report destination (c/s1/s2) [c]:  

At this Prompt, Press <ALT><F1> to turn on the log capture of Procomm.  You will be 

prompted for a file name as above. (Example “C:\STRIPPER\TERM.RPT”)  Enter the path 

and filename for your termination report and press (Enter).  The status bar will say “Log 

OPEN”. 

 

You will then see the following prompts: 
 

Termination Billing Report 

Enter account to report (hit return to exit) * 

The termination report works differently than the billing report.  You must enter the mailbox 

number(s) one at a time, and it will not accept ranges or group codes.  However, it does supply 

up to the minute information.  Enter each mailbox number in sequence that you would like 

statistics for.  You may sometimes get a warning, ignore it, and when asked for the base rate, 

simply press enter.  Do this for each mailbox.  When you are done, press “ENTER” to exit. 
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Once the Billing or Termination report is finished, you will be back at the Billing Report Sub-

menu prompt.  Press <ALT>[F1] again to turn off the log file report.  (Status bar will then 

display “Log CLOSED”).  At this point the report has been downloaded from your Centigram to 

your PC. 

 

You may selectively continue to download billing and termination reports into the Stripper 

directory (C:\STRIPPER\) as necessary.  Make sure that each one has a unique 8 letter 

description and ends with the extension of  “.RPT” 

 

 

When you are finished downloading: 

 

Log off from the Centigram, enter “X” to all menus back to the main menu.  When you are 

logged off, The Centigram will say “Console shut down, press CTRL-Z to 

reactivate”.   

 

If you did not sign on through a “Log In” prompt, you can exit Procomm by pressing 

<ALT><X> and answering “Yes to the “Exit Procomm?” Prompt. 

   

If you signed on at the “Log in” prompt, you will need to exit back to the Network prompt 

again by pressing ~.[ENTER].   

This will return you to the Menu, exit the menu and then exit Procomm as described above.   

 

You are now ready to run the Stripper program and Process the downloaded data. 
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Step Two:  Run Stripper 
 

Access Stripper at the DOS prompt by entering the following commands: 

 
CD\STRIPPER 

STRIPPER 

Main Screen: 
 

S T R I P P E R 

Billing Report Condensing Utility 

Version 1.23 

05-25-96 

by 

Stephen R. Strowbridge, Jr. 

Report Files on Disk: 

 

1: DFB0295 2: DFB0395  3: DFB0495  4:WPB0295  5: WPB0395 

6: WPB0495 

 

 

 

[S]trip Report File   Delete [R]eport File   Delete [T]ext File  E[X]it Stripper 

 

Program Options: 

 

Press: S To Strip a Report (.RPT) File 

 R To Delete a downloaded Report (.RPT) File 

 T To Delete a Stripped Text File (.TXT) 

 X to Exit the Stripper Program 

  

 

Stripping a Report File: 

The Stripper main screen shows the names of all downloaded billing report files in it’s directory.  

Each name has a number next to it. To Strip a particular report file, you my either first press 

“S”, followed by the number of the report file you wish to strip, or you may simply press the 

number of that report file.  (Pressing the number only works for the first 9 reports stored, 

additional ones will require you to press “S”). 

 

Upon selecting the report file you wish to strip, you will be presented with a few “Custom 

Options” for stripping the report. 
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Custom Options for Stripping a Report File: 

[E] Exclude a particular Group 

[I] Include a particular Group 

[ENTER] Strip Entire Report File 

[D] Don’t Strip this Report File (also <ESC>) 

 

The custom options Allow Stripper to “Strip” even more out of the report.  If you wish to strip 

the entire report, simply press [ENTER] and Stripper will prompt you for an output file name and 

do so. 

 

When specifying the output file name for your Stripped report file, you have the capability to 

combine statistics from different companies and even from different month’s billing reports into 

one file, by specifying the same output name each time. 

 

When you enter a name for your output file, “OUTPUT”, for example, if the file already exists, 

Stripper will tell you so, and ask if you wish to “A” Append to it, “O” Overwrite it, or Cancel by 

pressing <ESC>. 

 

Appending to the file will add the new statistics to the end of the existing ones.  Overwriting the 

file creates a new report containing only the current statistics to be stripped. 

 

Excluding Groups: 

This option will tell stripper to Exclude a particular group that you specify.  You will be 

prompted for a FULL or PARTIAL group code to exclude, and ALL MAILBOXES that match 

the criteria of the EXCLUSION will be omitted from the Stripper output file. 

 

Note that you may enter PARTIAL descriptions, as well, and stripper will EXCLUDE every 

mailbox that has a group code BEGINNING with a partial description.  You should also note that 

these EXCLUSIONS are “CASE sensitive”, whereas, if you ask to exclude “ABC”, everything 

beginning with “ABC” will be omitted, however, mailboxes containing “abc” will not. 

 

Including Groups: 

This handy option saves you the time to download custom billing reports from the Centigram, 

and if you have a complete billing report for a particular month, you may Strip it, INCUDING 

only the Group/Company code that you wish to have statistics for.  You may even save the 

results in a custom file name. 

 

As with the exclusion, specify a FULL or PARTIAL group code to INCLUDE (CASE sensitive), 

and stripper will only report the mailboxes meeting the specified criteria, ALL OTHER 

mailboxes will be excluded from the output. 

 

You may combine several different INCLUSION reports into one by specifying the SAME 

OUTPUT FILENAME each time, and then “A” APPEND to the file. 
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File Maintenance: 

Stripper allows you to “Clean Up” unneeded work files in it’s directory.  

 

The Report (RPT) file, is the actual billing report downloaded in its entirety from the 

Centigram.  This file will, in most cases, be quite large, consuming lots of hard disk space.  After 

you have Stripped this file by pressing “S”, and completed your Spread sheet, you can delete 

these from your hard disk by pressing “R”.  Make sure you delete them ONLY AFTER you have 

the complete spreadsheet.  Once they are deleted, the only way to get them back is to download 

them from the Centigram, AGAIN!  Also bear in mind that you can only retrieve information 

from the Centigram one or two months back from your current month, so if you feel that you may 

need to retrieve information from a report 3 or more months down the road you might want to 

keep it. 

 

The Text (TXT) file, is the “Stripped” RPT file, which is formatted into columns, with headings 

and totals, and is ready to be imported into Excel.  It is considerably smaller than the RPT file, 

but they can start to eat up space on your disk as well.  You can also delete these files by pressing 

“T” after you have completed your spread sheet, and if you accidentally delete one, you can get it 

back by “Re-Stripping” the RPT file of the same name. (Granted you haven’t deleted the RPT 

file). 

 

Typical Procedure: 

1. Download Centigram Billing Report into “C:\STRIPPER” 

2. Run Stripper 

3. Press “S” to Strip, and choose file number(s). 

4. Exit Stripper and Run Excel, and format the spreadsheet based on the Stripped TXT file(s) in 

directory “C:\STRIPPER” (All of which is outlined in Step 3 on the following page) 

 

AFTER you have created and printed your spreadsheets, for file maintenance: 

 

1. Run Stripper 

2. Choose “T” to delete the unneeded TXT files, (Delete the text files first) 

3. Choose “R” to delete the unneeded RPT files 

 

To exit Stripper, press “X” when you are at the main screen and are not in a prompt. 
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Step Three: Creating Excel Spreadsheet 
 

You are now ready to Process the Stripped report.  Once it has been converted into a spreadsheet, 

you will have a lot of flexibility on customizing it.  You can Sort your report on any one of the 

fields, like the user name or group code or mailbox number. 

 

Load Excel by first loading Windows, then double clicking on the Excel Icon from the 

appropriate group in your program manager. Once Excel is loaded, pull down the “File” menu, 

by either pressing <ALT><F> or clicking on the word “File” with your mouse.  Then select 

“Open” by either pressing “O” or clicking on the word “Open” with your mouse.   

 

 

“Open File”  Dialog Box: 

 
 

 

 

The first thing you will want to do it to change the file Type by clicking on the arrow above.  

You will want to change the file type to Text files “.TXT”  The next thing you will want to is to 

select the Directory C:\STRIPPER from the Center dialog box above under the heading 

Directories:  Do this by first double clicking on the C:\ open folder icon, then scrolling 

down until you find the STRIPPER folder, and double click on that.  From there all text files 

will be listed in the left most dialog box, under the heading File Name: 

 

Then lastly, double click on the appropriate “.TXT” file name to bring it into Excel. 
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Configuring Input fields: 

 

Microsoft Excel version 5.0 came out with a handy new feature for inputting text files in a 

“parsed” format, where each distinguishable field of information can be placed in a separate 

column in the spreadsheet.  This is called the “Text import Wizard”.  

 

When you have selected the text file that you wish to open, you will be presented with the 

Import Wizard Dialog box.  The heading will begin by saying “Text Import Wizard Step 1 of 3”.  

Click on the Next> button to be presented with Step 2 and a screen similar to the following: 

 

“Text Import Wizard Step 2 of 3” 

 
 

The vertical line placement is what separates each field into cells of the spreadsheet.  You will 

most likely need to add or move a few lines until all fields are separated. The best positions to 

have these lines in are: 9, 29, 39, 47, 55, 63, 71, 79, 87, 95, 103.  To add a separating line, simply 

click anywhere in the white area where you want to place it.  You can then “drag” it to an exact 

position.  It would be a good idea to scroll through  the data fields to make sure that all columns 

are consistently separated and that none “run over” into another column. All columns don’t fit in 

the view Window, so it will be necessary to scroll to the right. 

 

When you are satisfied that all the columns are equally separated, simply click on the “Finish” 

button.  Excel will do the rest.   

 

At this point, the “Stripped” text file is now an Excel spread sheet.  This first thing you will want 

to do is to pull down the “File” menu again, select “Save As...” then change the file Type 

to Excel Workbook.  Then select the C:\EXCEL directory and click on “OK”.   
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Step Four:  Customizing your Excel Report 
 

Sample Excel 5.0 Screen: 

 

 

The information of your Stripper report will be in 12 columns of your Excel spread sheet (A-L).  

There are five things you will need to do to create your report: 

 

1. Create column summaries (Optional) 

2. Define Print Area and Print Titles 

3. Sort Report (Optional)  

4. Set up column headings and widths 

5. Print Report 

 

Before you do those, now might be a good time to select the font character and 

size for the report.  You may either do this by choosing “Select ALL” from 

the Edit menu, or by selecting the Square just ABOVE The Row 1 and just 

LEFT of the Column A headers on your work sheet.  This should highlight 

(blacken) the entire sheet.   

 

The font and character size you will want to select are Arial, 10 point.  There are a few ways to 

this, one of which is to pull down the Format menu, select “Character” or “Font”, then 

Select “Arial”, “10 point”, “normal” from the dialog box, and then click on “OK”. 

 

Creating Column Summaries: 

Press <CTRL><END> to reach then end of the spread sheet.  Press <HOME> to return to Column 

A of the last line with “Total Records”.  Move the Arrow keys or mouse to Column D of that 

line.  Press the “Auto Sum” button on your toolbar.  The auto sum button has a strange “” 

looking character on it.  Press Enter. 

 You may repeat this step though column L, or if you are an advanced Excel user, you can 

“Drag and Drop” the summary all the way across.  (Note, you may wish to place a border around 

the summaries, also, Stripper has also included the totals, this is just a confirmation.) 
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Defining Print Area: 

If you are using Excel 5.0,  Select “Page Setup” in the File Menu, click on “Sheet”, then 

click in the area that says “Print Area” to get a cursor blinking in the field, finally, click on 

the sheet itself, outside of the dialog box.   

 

Both Versions of Excel: 

Press <CTRL><END> again, then HOLD DOWN the (SHIFT) button, and then press 

<CTRL><HOME>.  The entire spreadsheet will then be highlighted.  While continuing to HOLD 

DOWN the SHIFT button, Press the Down Arrow until the highlighted area is just below the 

column headings (Row 6).  

 

In Excel 4.0 Select “Set Print Area” from the Options Menu, Press Enter or Click on 

“OK”.  In Excel 5.0, the sheet will be highlighted by a dashed line border, move your mouse 

back to the dialog box of “Page Setup” and click on the “OK” button. 

 

The highlighted area will be selected as the printable spreadsheet. 

 

Sorting Report (Optional): 

Note:  By default, your Billing Report will be downloaded in Mailbox # order,  If this the desired 

format, you may choose to skip the sort routine. 

 

Press <CTRL><END> then <HOME>.  Move the Cursor just ABOVE the line that has the “Total 

Records” and Column Summaries.  Move the cursor over to column L of that line. 

 

HOLD DOWN the (SHIFT) Button, and press <CTRL><HOME>.  Every thing except the last 

line should now be highlighted.  While Still HOLDING DOWN SHIFT press the DOWN 

ARROW until the Report Headings are excluded (Row 6). 

 

Select The Data Menu.  If you are using Excel 4.0, you must first choose “Set Database”.  

Click on “Sort”.  A dialog box will appear offering three fields to sort on, and each can be 

either in Ascending or Descending order.  Note that the first choice is the Primary sort field, and 

each subsequent sort field, if selected will be sub sorted within it’s preceding sort category.   

Once you have selected the sort criteria, press “OK”.  The report is now sorted. 

 For example, if you wanted your entire billing report sorted by the group code “ID”, set 

the primary sort field to be column “C” then click on “OK”. 
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Setting up Column Headings and Widths: 

 

Press <CTRL><HOME>.  Using your mouse, Click on The row number “1” Just to the left of 

Column (A1) and then, HOLDING DOWN the left mouse button, DRAG the mouse down to 

Row number two.  The first two rows, including the numbers to the left of them should be 

highlighted.  Press the right mouse button.  Select “Insert” from the pop up menu.   

 

Select these 

two rows: 

 

You should now have two blank lines just ABOVE the Column Headings of your spreadsheet.  

Line 1 & 2 are yours to head your report.  An example would be: 

 

 A 
1 Voice-Tel of South Florida 

2 Billing Report, May, 1996 

 

Stripper places column headings in each cell for you, using three rows.  For a better visual effect, 

you can delete the fourth row with the “dashes”, and place a “border” around each of the 

previous three for each column. 

 

Next you will need to set the column widths for each column.  

The easiest way to do this is to click on the Letter column header 

“A” for example with the Right mouse button, this will highlight 

that column, and pop up a menu will appear, select “Set Column 

Width..” and enter the appropriate number as defined in the chart 

below. 

 

The Column Widths are suggested to be configured as follows: 

 

A B C D E F G H I J K L 

8 22 14 7 7 7 7 9 7 7 7 7 

 

Setting Print Titles: 

The last thing you will need to do before printing is to set the Print Titles, which will repeat on 

each page of the report.  This is the information you’ve defined as your report header in the first 

five rows.   
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Setting Print Titles, Continued: 

 

Choose “Page Setup” from the File menu, then choose “Sheet”.  Click in the box that says 

“Rows to repeat at top” with the mouse, then with the mouse, highlight the first five 

rows as described above ($1:$5), and click on “OK”. 

 

If you haven’t already, Select “Page Setup” from the File Menu. 

Select the “Margins” Section, and input the following: 
Top:  1.0” 

Bottom: 0.5” 

Left: 0.125” 

Right: 0.125” 

Header: 0” 

Footer: 0.25” 

 

Disable Grid lines by removing the “” or bullet “” ( “Sheet” section of 5.0).  

Select “Header/Footer” section and disable the header.   Add a “Custom Footer” of  

“Page &Page of &Pages”  Which will show as “Page X of Y” 

 

Select “Print Preview” and make sure that all 12 Columns fit your page.  It might be 

necessary to adjust the margins and/or column widths to accommodate all the information and fit 

it to your page.   

 

Printing the Report: 

The Last Step ! 

It might be a good time to save your spreadsheet again.   

Click on the toolbar button with the picture of the printer !   

(Make sure the print preview shows the entire width of the sheet fitting on each page) 

It’s suggested that you print your report on continuous form so it can be bound. 

 

Notes: 

It is virtually impossible to outline all the wonderful things you could do with your report using 

Excel.  Excel is very versatile, and with a little creativity and imagination, you can create first 

class presentations. 

 

Don’t forget  you can run your billing report or Strip only  selected criteria, as well.  For 

example, a range of mailboxes, or an individual ID code, which you could then create custom 

reports for your clients and sales staff very quickly and easily.  This proves to be a wonderful 

analysis tool, especially for companies on a pilot program. 
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 Disclaimer of Warranty 
 

This Software is provided “AS-IS” and the purchaser accepts the entire risk as to the quality and 

performance of the Software.  The vendor of this Software expressly disclaims all warranties, 

whether express or implied, including the implied warranties of mechantability and fitness for a 

particular purpose.  In no event shall the vendor of this Software be liable to the purchaser or any 

other party for any damages, including lost profits, lost data or other incidental or consequential 

damages, arising out of the use or inability to use the Software.   No oral or written information 

or advice given by the Vendor  or any related parties to the Vendor shall change any of the 

foregoing Disclaimers.  The Vendor’s entire liability to the purchaser and the purchaser’s sole 

and exclusive remedy shall be the refund of the purchase price. 

 

 

Trademark and Copyright Information: 

 

Various hardware and software manufacturer’s names and product/brand names along with 

actual software screen reproductions have been used in this manual, and are used entirely 

WITHOUT the permission of the respective companies. 

 

The following credits are issued to the best of our abilities: 

 

Microsoft, MS-DOS, DOS, Windows, “Arial” and Excel 

 registered trademarks of the Microsoft corporation. 

 

Centigram 

 Centigram Corporation 

 

Procomm and Procomm Plus: 

 Data Storm Technologies, Inc. 

 

 

 

PS 

It’s not polite to distribute illegal copies of ANY software!  


